// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(>[^<]*)(search string)([^>]*<)").unwrap();
let string = "<td>test regexp find search string in text and tags<\\td>";
let substitution = "$1transform string$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}