const regex = /(>[^<]*)(search string)([^>]*<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(>[^<]*)(search string)([^>]*<)', 'gm')
const str = `<td>test regexp find search string in text and tags<\\td>`;
const subst = `$1transform string$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);