using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(>[^<]*)(search string)([^>]*<)";
string substitution = @"$1transform string$3";
string input = @"<td>test regexp find search string in text and tags<\td>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}