package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(>[^<]*)(search string)([^>]*<)`)
var str = `<td>test regexp find search string in text and tags<\td>`
var substitution = "$1transform string$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}