// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[a-zA-z\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\-]+( )+?=( )+?(:id)").unwrap();
let string = " id = :id
id = id
SELECT * FROM A ID IN (select ID from users where id_ec = :id)
select * from users where id = :id and name = :name
select * from users where name = :name and id = :id aNd name = :name
select * from users where name = :name and name = :name and id = :id";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}