#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)[a-zA-z\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\-]+( )+?=( )+?(:id)"
Local $sString = " id = :id" & @CRLF & _
" id = id" & @CRLF & _
"" & @CRLF & _
"SELECT * FROM A ID IN (select ID from users where id_ec = :id)" & @CRLF & _
"" & @CRLF & _
"select * from users where id = :id and name = :name" & @CRLF & _
"" & @CRLF & _
"select * from users where name = :name and id = :id aNd name = :name" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"select * from users where name = :name and name = :name and id = :id"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")