const regex = /[a-zA-z\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\-]+( )+?=( )+?(:id)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-z\\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\\-]+( )+?=( )+?(:id)', 'gmi')
const str = ` id = :id
id = id
SELECT * FROM A ID IN (select ID from users where id_ec = :id)
select * from users where id = :id and name = :name
select * from users where name = :name and id = :id aNd name = :name
select * from users where name = :name and name = :name and id = :id`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}