re = /[a-zA-z\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\-]+( )+?=( )+?(:id)/mi
str = ' id = :id
id = id
SELECT * FROM A ID IN (select ID from users where id_ec = :id)
select * from users where id = :id and name = :name
select * from users where name = :name and id = :id aNd name = :name
select * from users where name = :name and name = :name and id = :id'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end