import Foundation
let pattern = #"([0-9]+)([a-zA-Z]+)([0-9]+)|([a-zA-Z]+)([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
1111NguyenThiAnh21111hoangHongphuong561111NguyenThiDiemThuy241111vuthiHuyen571111TruongNgocHuong91111DothiAnhTuyet641111NguyenThanhNguyen191111nguyenThiTrucDan58 1111ngThiThanhTrang60
1111PhamThiNgocMai141111DoThiNga151111ngTTHien59
1111NguyenThiHien61111NguyenThiThao231111tranthilananh451111TuongThiHongUyen291111ngthingocdiem461111DoThiNga161111NguyenThiKieuTrang261111Damthitam471111NguyenThiTuyetNga17ngthiThucVien~611111BuiThiThanhHuyen111111NgThiThucVien621111DangThiHoa81111NgNgocMinh631111VuongThiTuyetXuan311111phamthihuyen481111HoThiThanhThuy251111hoangthiHang49vuthongPhuong51 1111phanThiphuong50"Nguyenminhly38#1111vuthihongphuong52%1111nguyenduckinh53&1111phamthiquyen42(1111ngthhnga54)1111ngThuyanhoa55
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)