use strict;
my $str = '1111NguyenThiAnh21111hoangHongphuong561111NguyenThiDiemThuy241111vuthiHuyen571111TruongNgocHuong91111DothiAnhTuyet641111NguyenThanhNguyen191111nguyenThiTrucDan58 1111ngThiThanhTrang60
1111PhamThiNgocMai141111DoThiNga151111ngTTHien59
1111NguyenThiHien61111NguyenThiThao231111tranthilananh451111TuongThiHongUyen291111ngthingocdiem461111DoThiNga161111NguyenThiKieuTrang261111Damthitam471111NguyenThiTuyetNga17ngthiThucVien~611111BuiThiThanhHuyen111111NgThiThucVien621111DangThiHoa81111NgNgocMinh631111VuongThiTuyetXuan311111phamthihuyen481111HoThiThanhThuy251111hoangthiHang49vuthongPhuong51 1111phanThiphuong50"Nguyenminhly38#1111vuthihongphuong52%1111nguyenduckinh53&1111phamthiquyen42(1111ngthhnga54)1111ngThuyanhoa55';
my $regex = qr/([0-9]+)([a-zA-Z]+)([0-9]+)|([a-zA-Z]+)([0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}