#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]+)([a-zA-Z]+)([0-9]+)|([a-zA-Z]+)([0-9]+)"
Local $sString = "1111NguyenThiAnh21111hoangHongphuong561111NguyenThiDiemThuy241111vuthiHuyen571111TruongNgocHuong91111DothiAnhTuyet641111NguyenThanhNguyen191111nguyenThiTrucDan58 1111ngThiThanhTrang60" & @CRLF & _
"1111PhamThiNgocMai141111DoThiNga151111ngTTHien59" & @CRLF & _
"1111NguyenThiHien61111NguyenThiThao231111tranthilananh451111TuongThiHongUyen291111ngthingocdiem461111DoThiNga161111NguyenThiKieuTrang261111Damthitam471111NguyenThiTuyetNga17ngthiThucVien~611111BuiThiThanhHuyen111111NgThiThucVien621111DangThiHoa81111NgNgocMinh631111VuongThiTuyetXuan311111phamthihuyen481111HoThiThanhThuy251111hoangthiHang49vuthongPhuong51 1111phanThiphuong50"Nguyenminhly38#1111vuthihongphuong52%1111nguyenduckinh53&1111phamthiquyen42(1111ngthhnga54)1111ngThuyanhoa55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")