// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]+)([a-zA-Z]+)([0-9]+)|([a-zA-Z]+)([0-9]+)").unwrap();
let string = "1111NguyenThiAnh21111hoangHongphuong561111NguyenThiDiemThuy241111vuthiHuyen571111TruongNgocHuong91111DothiAnhTuyet641111NguyenThanhNguyen191111nguyenThiTrucDan58 1111ngThiThanhTrang60
1111PhamThiNgocMai141111DoThiNga151111ngTTHien59
1111NguyenThiHien61111NguyenThiThao231111tranthilananh451111TuongThiHongUyen291111ngthingocdiem461111DoThiNga161111NguyenThiKieuTrang261111Damthitam471111NguyenThiTuyetNga17ngthiThucVien~611111BuiThiThanhHuyen111111NgThiThucVien621111DangThiHoa81111NgNgocMinh631111VuongThiTuyetXuan311111phamthihuyen481111HoThiThanhThuy251111hoangthiHang49vuthongPhuong51 1111phanThiphuong50\"Nguyenminhly38#1111vuthihongphuong52%1111nguyenduckinh53&1111phamthiquyen42(1111ngthhnga54)1111ngThuyanhoa55";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}