re = /^[1]?[0-9]:[0-5][0-9][\s]?[APap][mM]$/m
str = '12:45pm
9:59 AM
6:60am
10:02pm
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end