const regex = new RegExp('^[1]?[0-9]:[0-5][0-9][\\s]?[APap][mM]$', 'gm')
const str = `12:45pm
9:59 AM
6:60am
10:02pm
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}