package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1]?[0-9]:[0-5][0-9][\s]?[APap][mM]$`)
var str = `12:45pm
9:59 AM
6:60am
10:02pm
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}