using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1]?[0-9]:[0-5][0-9][\s]?[APap][mM]$";
string input = @"12:45pm
9:59 AM
6:60am
10:02pm
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}