import Foundation
let pattern = ##"\"-- starting hand \#(?P<handnum>\d+) \(id: (?P<handid>[a-z0-9]+)\) \((?P<gametype>.*?)\) \(dealer: \"\"(?P<buttonplayer>.*?)\"\"\) --\",(?P<handutc>.*?),(?P<handseqno>.*$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##""-- starting hand #7 (id: tooolqqevl05) (No Limit Texas Hold'em) (dealer: ""michael @ VEYRadLj9o"") --",2023-01-14T21:49:44.596Z,167373298459600"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)