import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"-- starting hand \\#(?P<handnum>\\d+) \\(id: (?P<handid>[a-z0-9]+)\\) \\((?P<gametype>.*?)\\) \\(dealer: \\\"\\\"(?P<buttonplayer>.*?)\\\"\\\"\\) --\\\",(?P<handutc>.*?),(?P<handseqno>.*$)";
final String string = "\"-- starting hand #7 (id: tooolqqevl05) (No Limit Texas Hold'em) (dealer: \"\"michael @ VEYRadLj9o\"\") --\",2023-01-14T21:49:44.596Z,167373298459600";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}