// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"-- starting hand \#(?P<handnum>\d+) \(id: (?P<handid>[a-z0-9]+)\) \((?P<gametype>.*?)\) \(dealer: \"\"(?P<buttonplayer>.*?)\"\"\) --\",(?P<handutc>.*?),(?P<handseqno>.*$)"#).unwrap();
let string = "\"-- starting hand #7 (id: tooolqqevl05) (No Limit Texas Hold'em) (dealer: \"\"michael @ VEYRadLj9o\"\") --\",2023-01-14T21:49:44.596Z,167373298459600";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}