const regex = new RegExp('\\"-- starting hand \\#(?P<handnum>\\d+) \\(id: (?P<handid>[a-z0-9]+)\\) \\((?P<gametype>.*?)\\) \\(dealer: \\"\\"(?P<buttonplayer>.*?)\\"\\"\\) --\\",(?P<handutc>.*?),(?P<handseqno>.*$)', 'gm')
const str = `"-- starting hand #7 (id: tooolqqevl05) (No Limit Texas Hold'em) (dealer: ""michael @ VEYRadLj9o"") --",2023-01-14T21:49:44.596Z,167373298459600`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}