import Foundation
let pattern = #"([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2\U$3\E"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)