const regex = /([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([aeiouy])(\\s*)([bcdfghjklmnpqrstvwxz])', 'gmi')
const str = `hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog`;
const subst = `$1$2\U$3\E`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);