$re = '/([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])/mi';
$str = 'hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog';
$subst = "$1$2\U$3\E";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;