re = /([aeiouy])(\s*)([bcdfghjklmnpqrstvwxz])/mi
str = 'hello world
xaabeuekadii
A quick brown fox jumps over the lazy dog'
subst = '$1$2\\U$3\\E'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result