re = /((--\S+=\S+|--\S+)(?=\s+|\S+|$))/m
str = '--flag --k1=v1 --k2=v2 -k3=v3 --k4=v4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end