using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((--\S+=\S+|--\S+)(?=\s+|\S+|$))";
string input = @"--flag --k1=v1 --k2=v2 -k3=v3 --k4=v4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}