$re = '/((--\S+=\S+|--\S+)(?=\s+|\S+|$))/m';
$str = '--flag --k1=v1 --k2=v2 -k3=v3 --k4=v4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);