const regex = /((--\S+=\S+|--\S+)(?=\s+|\S+|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((--\\S+=\\S+|--\\S+)(?=\\s+|\\S+|$))', 'gm')
const str = `--flag --k1=v1 --k2=v2 -k3=v3 --k4=v4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}