import Foundation
let pattern = #"(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
www.xakep.ru
https://swapi.co/api/planets/12/ //swapi
http://github.com/carbonfive/raygun //github
http://www.zombie-bites.com //
https://www.cnet.com
http://google.co.jp
http://github.com/carbonfive/raygun
https://www.cnet.com
xewveqmwcz90sl64.co/
zx06u3ep-tcp8b25l.info
j4yfack7z7pui8b8j-d3-abfdvp.it/img/
z8rabv26m.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)