package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)`)
var str = `www.xakep.ru
https://swapi.co/api/planets/12/ //swapi
http://github.com/carbonfive/raygun //github
http://www.zombie-bites.com //
https://www.cnet.com
http://google.co.jp
http://github.com/carbonfive/raygun
https://www.cnet.com
xewveqmwcz90sl64.co/
zx06u3ep-tcp8b25l.info
j4yfack7z7pui8b8j-d3-abfdvp.it/img/
z8rabv26m.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}