const regex = /(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(www.|https?:\\\/\\\/(?:www.)?)?([a-z-_0-9]*)(?:\\.)', 'gm')
const str = `www.xakep.ru
https://swapi.co/api/planets/12/ //swapi
http://github.com/carbonfive/raygun //github
http://www.zombie-bites.com //
https://www.cnet.com
http://google.co.jp
http://github.com/carbonfive/raygun
https://www.cnet.com
xewveqmwcz90sl64.co/
zx06u3ep-tcp8b25l.info
j4yfack7z7pui8b8j-d3-abfdvp.it/img/
z8rabv26m.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}