$re = '/(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)/m';
$str = 'www.xakep.ru
https://swapi.co/api/planets/12/ //swapi
http://github.com/carbonfive/raygun //github
http://www.zombie-bites.com //
https://www.cnet.com
http://google.co.jp
http://github.com/carbonfive/raygun
https://www.cnet.com
xewveqmwcz90sl64.co/
zx06u3ep-tcp8b25l.info
j4yfack7z7pui8b8j-d3-abfdvp.it/img/
z8rabv26m.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);