// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)B(?:A|I|O(*ACCEPT))Z").unwrap();
let string = "BIZ
BOZ
BAZ";
let substitution = "Hi";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}