using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B(?:A|I|O(*ACCEPT))Z";
string substitution = @"Hi";
string input = @"BIZ
BOZ
BAZ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}