use strict;
my $str = 'BIZ
BOZ
BAZ';
my $regex = qr/B(?:A|I|O(*ACCEPT))Z/mp;
my $subst = 'Hi';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";