$re = '/B(?:A|I|O(*ACCEPT))Z/m';
$str = 'BIZ
BOZ
BAZ';
$subst = "Hi";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;