// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[1-9])").unwrap();
let string = "192.168.1.1
8.8.8.8
9.9.9.9
127.0.0.1
255.255.255.255 # can't end in 255, reserved for broadcast
0.0.0.0 # can't end in 0, i don't know what that's reserved for
0.0.0.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}