$re = '/((25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[1-9])/m';
$str = '192.168.1.1
8.8.8.8
9.9.9.9
127.0.0.1
255.255.255.255 # can\'t end in 255, reserved for broadcast
0.0.0.0 # can\'t end in 0, i don\'t know what that\'s reserved for
0.0.0.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);