use strict;
my $str = '192.168.1.1
8.8.8.8
9.9.9.9
127.0.0.1
255.255.255.255 # can\'t end in 255, reserved for broadcast
0.0.0.0 # can\'t end in 0, i don\'t know what that\'s reserved for
0.0.0.1
';
my $regex = qr/((25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[1-9])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}