#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[1-9])"
Local $sString = "192.168.1.1" & @CRLF & _
"8.8.8.8" & @CRLF & _
"9.9.9.9" & @CRLF & _
"127.0.0.1" & @CRLF & _
"255.255.255.255 # can't end in 255, reserved for broadcast" & @CRLF & _
"0.0.0.0 # can't end in 0, i don't know what that's reserved for" & @CRLF & _
"0.0.0.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")