import Foundation
let pattern = #"(?![aeiou])[a-z]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
regex="[a-z&&[^aeiou]]";
source="Only the Lowercase Consonants Should Be Matched.";
Regex_Skeleton.displayHighlightedResults(regex, source);
regex="(?:(?![aeiou])[a-z])";
Regex_Skeleton.displayHighlightedResults(regex, source);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)