#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?![aeiou])[a-z]"
Local $sString = "regex="[a-z&&[^aeiou]]";" & @CRLF & _
" source="Only the Lowercase Consonants Should Be Matched.";" & @CRLF & _
" Regex_Skeleton.displayHighlightedResults(regex, source);" & @CRLF & _
" regex="(?:(?![aeiou])[a-z])"; " & @CRLF & _
" Regex_Skeleton.displayHighlightedResults(regex, source);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")