$re = '/(?![aeiou])[a-z]/';
$str = 'regex="[a-z&&[^aeiou]]";
source="Only the Lowercase Consonants Should Be Matched.";
Regex_Skeleton.displayHighlightedResults(regex, source);
regex="(?:(?![aeiou])[a-z])";
Regex_Skeleton.displayHighlightedResults(regex, source);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);