use strict;
my $str = 'regex="[a-z&&[^aeiou]]";
source="Only the Lowercase Consonants Should Be Matched.";
Regex_Skeleton.displayHighlightedResults(regex, source);
regex="(?:(?![aeiou])[a-z])";
Regex_Skeleton.displayHighlightedResults(regex, source);';
my $regex = qr/(?![aeiou])[a-z]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}