import Foundation
let pattern = #"^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
02_AUT_M_PHY M-2015-12
02_GASPOOL_H_M_PHY M-2015-12
02_GASPOOL_L_M_PHY M-2015-12
02_NBP_H_M_PHY M-2015-12
02_MGP_M_PHY M-2015-12
02_NCG_H_M_PHY M-2015-12
02_NCG_L_M_PHY M-2015-12
02_OTE_M1_PHY M-2015-12
02_POLVP_M2_PHY M-2015-12
02_PEGN_M3_PHY M-2015-12
02_SVKVP_M4_PHY M-2015-12
02_ZEEBRUGGE_H_M5_PHY M-2015-12
02_ZTP_H_M10_PHY M-2015-12
02_ZTP_L_M99_PHY M-2015-12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)