# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$"
test_str = ("02_AUT_M_PHY M-2015-12\n"
"02_GASPOOL_H_M_PHY M-2015-12\n"
"02_GASPOOL_L_M_PHY M-2015-12\n"
"02_NBP_H_M_PHY M-2015-12\n"
"02_MGP_M_PHY M-2015-12\n"
"02_NCG_H_M_PHY M-2015-12\n"
"02_NCG_L_M_PHY M-2015-12\n"
"02_OTE_M1_PHY M-2015-12\n"
"02_POLVP_M2_PHY M-2015-12\n"
"02_PEGN_M3_PHY M-2015-12\n"
"02_SVKVP_M4_PHY M-2015-12\n"
"02_ZEEBRUGGE_H_M5_PHY M-2015-12\n"
"02_ZTP_H_M10_PHY M-2015-12\n"
"02_ZTP_L_M99_PHY M-2015-12")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.