#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$"
Local $sString = "02_AUT_M_PHY M-2015-12" & @CRLF & _
"02_GASPOOL_H_M_PHY M-2015-12" & @CRLF & _
"02_GASPOOL_L_M_PHY M-2015-12" & @CRLF & _
"02_NBP_H_M_PHY M-2015-12" & @CRLF & _
"02_MGP_M_PHY M-2015-12" & @CRLF & _
"02_NCG_H_M_PHY M-2015-12" & @CRLF & _
"02_NCG_L_M_PHY M-2015-12" & @CRLF & _
"02_OTE_M1_PHY M-2015-12" & @CRLF & _
"02_POLVP_M2_PHY M-2015-12" & @CRLF & _
"02_PEGN_M3_PHY M-2015-12" & @CRLF & _
"02_SVKVP_M4_PHY M-2015-12" & @CRLF & _
"02_ZEEBRUGGE_H_M5_PHY M-2015-12" & @CRLF & _
"02_ZTP_H_M10_PHY M-2015-12" & @CRLF & _
"02_ZTP_L_M99_PHY M-2015-12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")