import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?'commodity'02)_(?'market'\\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\\d{4})-\\b(?'month'0[1-9]|1[0-2])\\b$";
final String string = "02_AUT_M_PHY M-2015-12\n"
+ "02_GASPOOL_H_M_PHY M-2015-12\n"
+ "02_GASPOOL_L_M_PHY M-2015-12\n"
+ "02_NBP_H_M_PHY M-2015-12\n"
+ "02_MGP_M_PHY M-2015-12\n"
+ "02_NCG_H_M_PHY M-2015-12\n"
+ "02_NCG_L_M_PHY M-2015-12\n"
+ "02_OTE_M1_PHY M-2015-12\n"
+ "02_POLVP_M2_PHY M-2015-12\n"
+ "02_PEGN_M3_PHY M-2015-12\n"
+ "02_SVKVP_M4_PHY M-2015-12\n"
+ "02_ZEEBRUGGE_H_M5_PHY M-2015-12\n"
+ "02_ZTP_H_M10_PHY M-2015-12\n"
+ "02_ZTP_L_M99_PHY M-2015-12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}