re = /[\S]*(?:\[%)(\w+)(?:%])(?:(?:[^\S\n]*=[^\S\n]*([^\n]*[\S])))?/m
str = '[%Variable%]
[%Another_One%] = Lots of characters but no trailing spaces
[%MoreVariables_44%] = NotWhiteSpace Sensistive
[%NoBlanksAllowed%] = '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end