$re = '/[\S]*(?:\[%)(\w+)(?:%])(?:(?:[^\S\n]*=[^\S\n]*([^\n]*[\S])))?/m';
$str = '[%Variable%]
[%Another_One%] = Lots of characters but no trailing spaces
[%MoreVariables_44%] = NotWhiteSpace Sensistive
[%NoBlanksAllowed%] = ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);